Latest Movie Trailers


Updated 02/01/2013Home » Guides » AVI to DVD Conversion Guide

AVI to DVD Conversion Guide

This guide explains in detail how to easily convert any AVI file into a standard DVD-Video disc with optional subtitle streams.

With this guide you can create a compatible DVD-Video from any AVI (DivX, XviD, etc) file.

If your source AVI file has a multichannel AC3 audio stream, even better: this guide explains how to create the DVD with the original AC3 sound included, since most DVD players support AC3 audio.

Step 1: Audio Extraction

Open your source video file with GSpot to find out the audio format used. Also take note of the FPS value indicated in the Video section.

  • If it's not an AC3 audio stream, need an uncompressed WAV file of large size.
  • If it's an AC3 audio stream, extract it this way:
Open your source AVI in VirtualDubMod, then go to Streams > Stream List. Select the audio stream you wish to extract and click Demux to save it as an AC3 file. This can take a few minutes accordingly to the movie length.

Step 2: AVI to MPEG2 Conversion

Open TMPEG Encoder and if the Project Wizard doesn't appear go to File > Project Wizard.



If your source video has 25 FPS, select DVD - PAL, otherwise select DVD - NTSC and click Next.

In the next step, click Browse to select the Video file only and click Next.
  • If your source video aspect ratio is not fullscreen: Enable the Clip frame option. In the popup window click Arrange setting  and from the drop-down list chose Fullscreen (Keep aspect ratio) option to ensure video will have a proper aspect ratio and size.


Now click the Other Settings buttonwhich will show this dialog:



Here you should select the Higest quality mode for Motion search precision, which takes longer to compress but improves quality noticeably. To increase quality even more, use the 2-pass VBR option for Rate control mode. Click OK and then Next. Now you should be at the Bitrate settings dialog.

In this last step you'll see additional conversion options. Video resolution should be 720x480 for NTSC video or 720x576 for PAL video. Once ready, click Next and then start encoding the file.

Note: TMPEG Encoder will generate a video file with MPG or M2V extension. Also, a WAV file may be generated as well. This WAV file is useless and can be deleted instantly.

Notice that TMPEG Encoder may take a few hours to finish the conversion on slower machines, therefore it is recommended to do this process at night or whenever the computer is not in use.

Step 3: DVD Authoring

Open DVD-lab Pro and in the Default Project dialog select the target format NTSC or PAL accordingly to the setting used previously in TMPEG Encoder. Also select the Simple (Movie Only) option, since our DVD-Video won't have special menus nor additional features.



Click OK to proceed.

To add the created MPEG-2 video and the extracted AC3 or WAV audio files, right click on the Assets zone and select Import. If you followed this guide perfectly, both audio and video files will be immediately added without problems.



After importing the files, drag and drop them from the Assets window to the Movie 1 area.

The audio stream is added as English by default. To change the stream language, click the Audio 1 button and select the proper language in the popup dialog.




Adding Subtitles [Optional]

To add a subtitle stream from a SUB, SRT, SSA or SON subtitle file, click the Sub 1 button. In the Subtitle window click Import and open yout subtitle file. To ensure the subtitle file is error-free, we recommend you to open it with DivXLand Media Subtitler to adjust or correct it.



Make sure to chose a clear font and size. Here we are using 'Trebuchet MS' size 24. Click Generate Subtitle Stream and the subtitle stream will be generated and added automatically. You can add additional subtitle streams by clicking the Sub button and repeating the process..


To generate the DVD chapters, go to Movie > Auto Chapters.



Enter the amount of chapters to add and click OK.

Finally, go to the Project menu and select Compile DVD..



Select the output folder for the compiled DVD and click Start to begin. Notice that this operation will require several additional GB of free space to complete, see the charts to ensure there is enough disk space available.

Step 5: DVD Burning

We'll use the free tool Ashampoo Burning Studio 6 to burn the DVD, but you also can use Nero or whatever program you regularly use to burn DVD discs.

Start the program and select the Burn Movies > Burn a Video DVD from a Prepared Folder menu item.


In the next step, select the VIDEO_TS folder created earlier by DVD-lab Pro and press Next.



Insert a writable DVD of the required capacity into the drive and Ashampoo will check if the disc is OK. Then click the Write DVD button to start the process. It is recommended to use a low speed such as 4X to ensure the disc will be burned successfully without buffer problems.

Tip: To test the created DVD, open Media Player Classic and go to File > Open DVD. The video playback should begin immediately.

Comments

blog comments powered by Disqus